phpMyAdmin: the configuration file now needs a secret passphrase blowfish_secret

You could get the following error message in phpMyAdmin page, if you manually download and installed phpMyAdmin.

The configuration file now needs a secret passphrase (blowfish_secret).

To fix the error, you need to set $cfg['blowfish_secret'] = ''; in "config.inc.php" file with a key length of 32 chars long.

Example

$cfg['blowfish_secret'] = 'dw?]~-^"UD]n_-N`kFB<kgzG$tZvDj4z';
phpMyAdmin: the configuration file now needs a secret passphrase blowfish_secret

The config.inc.php file is in the phpmyadmin installation directory (ex. /usr/share/phpmyadmin).

The phpMyAdmin package comes with a sample config.inc.php, if config file does not exist copy sample file as "config.inc.php".

cp config.sample.inc.php config.inc.php